Discussion:
new ixgbe driver for kernel 4.1 and newer?
(too old to reply)
Stefan Priebe - Profihost AG
2015-09-21 15:02:50 UTC
Permalink
Hi,

the current ixgbe driver available is not compatible with kernel 4.1 and
newer.

Does anybody know when there is a newer version compatible with kernel 4.1?

Stefan

------------------------------------------------------------------------------
Rose, Gregory V
2015-09-21 15:54:43 UTC
Permalink
The 4.1 kernel should have an up to date driver included in the kernel.

- Greg
-----Original Message-----
Sent: Monday, September 21, 2015 8:03 AM
Subject: [E1000-devel] new ixgbe driver for kernel 4.1 and newer?
Hi,
the current ixgbe driver available is not compatible with kernel 4.1 and
newer.
Does anybody know when there is a newer version compatible with kernel 4.1?
Stefan
--------------------------------------------------------------------------
----
_______________________________________________
E1000-devel mailing list
https://lists.sourceforge.net/lists/listinfo/e1000-devel
To learn more about Intel® Ethernet, visit
http://communities.intel.com/community/wired
------------------------------------------------------------------------------
Stefan Priebe - Profihost AG
2015-09-21 16:28:07 UTC
Permalink
The included one is 4.0.1. sourceforge is at 4.1.2

Stefan

Excuse my typo sent from my mobile phone.
Post by Rose, Gregory V
The 4.1 kernel should have an up to date driver included in the kernel.
- Greg
-----Original Message-----
Sent: Monday, September 21, 2015 8:03 AM
Subject: [E1000-devel] new ixgbe driver for kernel 4.1 and newer?
Hi,
the current ixgbe driver available is not compatible with kernel 4.1 and
newer.
Does anybody know when there is a newer version compatible with kernel 4.1?
Stefan
--------------------------------------------------------------------------
----
_______________________________________________
E1000-devel mailing list
https://lists.sourceforge.net/lists/listinfo/e1000-devel
To learn more about Intel® Ethernet, visit
http://communities.intel.com/community/wired
Skidmore, Donald C
2015-09-21 16:52:36 UTC
Permalink
These version numbers don't mean as much as you would expect them too. We try very hard to keep the source forge driver has close as possible to the current in kernel driver but there are differences for various reasons. (i.e. kcompat issues, differing module parameters, etc). That said we are even a little bit more out of sync at the moment, after pushing some additional support upstream that hasn't been included in the source forge driver yet. My hope was to sync them back up around a 4.2.x version, in a month or two.

As for 4.1 kernel support, we are currently working on a point release for the source forge driver (4.1.x) that will include 4.1 kernel support. I expect it to be on source forge sometime later this week.

Thanks,
-----Original Message-----
Sent: Monday, September 21, 2015 9:28 AM
To: Rose, Gregory V
Subject: Re: [E1000-devel] new ixgbe driver for kernel 4.1 and newer?
The included one is 4.0.1. sourceforge is at 4.1.2
Stefan
Excuse my typo sent from my mobile phone.
Am 21.09.2015 um 17:54 schrieb Rose, Gregory V
The 4.1 kernel should have an up to date driver included in the kernel.
- Greg
-----Original Message-----
Sent: Monday, September 21, 2015 8:03 AM
Subject: [E1000-devel] new ixgbe driver for kernel 4.1 and newer?
Hi,
the current ixgbe driver available is not compatible with kernel 4.1
and newer.
Does anybody know when there is a newer version compatible with kernel 4.1?
Stefan
---------------------------------------------------------------------
-----
----
_______________________________________________
E1000-devel mailing list
https://lists.sourceforge.net/lists/listinfo/e1000-devel
To learn more about Intel® Ethernet, visit
http://communities.intel.com/community/wired
------------------------------------------------------------------------------
Loading...